GAMEBOOMERS provides you with all the latest PC adventure computer games information, forum, walkthroughs, reviews and news.

GB Reviews

Latest & Upcoming Adventure Games

GB Annual Game Lists

GB Interviews

BAAGS

GB @ acebook

About Us

Walkthroughs

free games galore

Game Publishers & Developers

World of Adventure

Patches

GB @ witter

GameBoomers Store

Big Fish Games Homepage
Page 2 of 3 < 1 2 3 >
Topic Options
#1119509 - 07/31/17 10:03 PM Re: dracula 3 the path of the dragon [Re: deleterman]
Jenny100 Offline
GB Reviewer Glitches Moderator
Sonic Boomer

Registered: 10/24/00
Posts: 38977
Loc: southeast USA
Apparently this "flicker" problem with Windows 10 and older games isn't limited to Dracula 3. Here's a thread about Tom Clancy's Rainbow Six
https://steamcommunity.com/app/19830/discussions/0/520518053446830141/
It's possible that some of the suggestions in the 2nd post might help -- like disabling vsync (in your video card's properties) or restricting the game to use a single processor.

Also a gamer at GOG forums claimed that changing the desktop color depth from 32-bit to 16-bit helped with stutter in the Dracula games.
https://www.gog.com/forum/dracula_series/dracula_fscreen_lickering

It's possible that using a Vista computer might help, if for no other reason than that the computer is older and isn't using Windows 10 drivers.

Top
#1119525 - 08/01/17 03:47 AM Re: dracula 3 the path of the dragon [Re: deleterman]
sanford Online   content
Addicted Boomer

Registered: 03/20/08
Posts: 1955
Loc: Hicksville, NY USA
Thanks everybody, for your valued input. I guess I'll install this game on my wife's Vista PC and give it a try. At this moment I can't remember what video card is installed in her pc, but I sure will find out tomorrow.Of course I'll be starting the game from the beginning, but i'm not too far along in this game anyway. Wish me luck! LOL. I'll give you an update by tomorrow.
Sandy

Top
#1119582 - 08/01/17 03:37 PM Re: dracula 3 the path of the dragon [Re: deleterman]
sanford Online   content
Addicted Boomer

Registered: 03/20/08
Posts: 1955
Loc: Hicksville, NY USA
SUCCESS
The game is running perfectly on the Vista PC. NO FLICKER! I guess that WIN 10 just doesn't like this game. I just started to play it from the beginning, so thank you all for your input. HAPPY GAMING!
Sandy

Top
#1119586 - 08/01/17 05:01 PM Re: dracula 3 the path of the dragon [Re: deleterman]
Jenny100 Offline
GB Reviewer Glitches Moderator
Sonic Boomer

Registered: 10/24/00
Posts: 38977
Loc: southeast USA
The Dracula 3 game box does list Vista.
I don't know if the problem is with Windows 10 itself or with poor video drivers for Windows 10.

Hope you enjoy it.

Top
#1119680 - 08/02/17 06:37 PM Re: dracula 3 the path of the dragon [Re: Jenny100]
sanford Online   content
Addicted Boomer

Registered: 03/20/08
Posts: 1955
Loc: Hicksville, NY USA
Thanks Jenny,
I AM enjoying it, and I've just caught up to the part that I was up to when it was on my WIN 10 pc. I'm "forging ahead" now. LOL
Sandy

Top
#1119693 - 08/02/17 09:59 PM Re: dracula 3 the path of the dragon [Re: deleterman]
Draclvr Offline
Hints & Glitches forum Moderator
Adept Boomer

Registered: 06/03/05
Posts: 13325
Loc: In Missouri near St. Louis
Good for you, Sandy!
_________________________
Heading out to the gardens...

Top
#1120024 - 08/06/17 03:15 AM Re: dracula 3 the path of the dragon [Re: deleterman]
Iurii Offline
Settled Boomer

Registered: 09/03/13
Posts: 550
Loc: Kiev, Ukraine
I now have that flickering problem on almost all Kheops games :(

I have Windows 7 x64 and nVidia card. Still, I do remember that the problem in question was indeed due to nVidia drivers - I had it before on drivers released between something like August 2015 and April 2016 (but not on older or newer drivers). However, I tried different drivers now, including those that used to work for me before, but no luck. Nothing helps - including compatibilities and drivers' tweaks. Only forcing the window mode (instead of fullscreen) works - but that is really not comfortable to play with.

All the newer titles are affected: "The Secret of Da Vinci", "Nostradamus", "Return to Mysterious Island 2", "Treasure Island", "Cleopatra", "Dracula 3" and "Safecracker".
Older games run fine: "Return to Mysterious Island", "Egypt 3", "Echo: The Lost Cavern" and "Journey to the Moon".

I have tried both switching to 16-bit color depth and the mentioned d3d8.dll fix for Windows 10 - nothing worked for me...

Top
#1120065 - 08/06/17 10:24 AM Re: dracula 3 the path of the dragon [Re: deleterman]
Draclvr Offline
Hints & Glitches forum Moderator
Adept Boomer

Registered: 06/03/05
Posts: 13325
Loc: In Missouri near St. Louis
Thanks for the great information, Iruii...
_________________________
Heading out to the gardens...

Top
#1120075 - 08/06/17 12:01 PM Re: dracula 3 the path of the dragon [Re: deleterman]
Jenny100 Offline
GB Reviewer Glitches Moderator
Sonic Boomer

Registered: 10/24/00
Posts: 38977
Loc: southeast USA
That's interesting, Iurii. From your list, Kheops games from 2006 and later are affected by flicker while those from 2004 and 2005 are not. Did Kheops increase their games' resolution in 2006?

Are you using the original disc versions of the games? Downloads may have been "updated" in some way.

Have you checked whether the Nvidia drivers are using specific per-game settings for any of the games that work vs those that have flicker?

Sometimes installing new drivers changes default settings, and going back to the older drivers doesn't necessarily change the settings back to the original defaults.

Have you checked whether Vsync is enabled or disabled in the games that work properly vs those that have flicker?

Top
#1120078 - 08/06/17 12:31 PM Re: dracula 3 the path of the dragon [Re: Jenny100]
Marian Offline
Global Moderator
Sonic Boomer

Registered: 07/04/00
Posts: 34132
Loc: near Yosemite in California
I found this old thread on GameBoomers where this problem was being discussed. It's been plaguing gamers with NVidia cards for a good long while now.

Top
#1120086 - 08/06/17 01:49 PM Re: dracula 3 the path of the dragon [Re: deleterman]
Iurii Offline
Settled Boomer

Registered: 09/03/13
Posts: 550
Loc: Kiev, Ukraine
Jenny100, I am using the original disc versions, but I have only Russian editions of them. However the flickering certainly does not seem to be a localization problem.

Of course, I have tried all the Vsync options, as well as adding the games with different specific settings to nVidia drivers. As I said, nothing worls except the good old 'bFullScreen=0' in config.ini. But the windowed mode is very inconvenient to play. Installing older nVidia drivers used to work for me before, but not now somehow, so I stay with the latest.

In Windows XP there are no such problems, by the way.

Top
#1120096 - 08/06/17 04:54 PM Re: dracula 3 the path of the dragon [Re: Iurii]
Jenny100 Offline
GB Reviewer Glitches Moderator
Sonic Boomer

Registered: 10/24/00
Posts: 38977
Loc: southeast USA
Originally Posted By: Iurii
Installing older nVidia drivers used to work for me before, but not now somehow...

That's why I asked about Nvidia default settings.
I've had them change between driver versions, and they don't necessarily change back if you go back to the older drivers.

I have to wonder if it's partially Microsoft's doing -- changing the way DirectX 11 works with DirectX 9 games.

Top
#1120131 - 08/07/17 01:34 AM Re: dracula 3 the path of the dragon [Re: deleterman]
Iurii Offline
Settled Boomer

Registered: 09/03/13
Posts: 550
Loc: Kiev, Ukraine
I have tried Steam editions as well (some games have them, not all) - the problem is present there, as many users complain.
And I have tried different nVidia settings of course.

Top
#1139097 - 01/21/18 04:01 AM Re: dracula 3 the path of the dragon [Re: Iurii]
Iurii Offline
Settled Boomer

Registered: 09/03/13
Posts: 550
Loc: Kiev, Ukraine
Originally Posted By: Iurii

All the newer titles are affected: "The Secret of Da Vinci", "Nostradamus", "Return to Mysterious Island 2", "Treasure Island", "Cleopatra", "Dracula 3" and "Safecracker".

OK, I was able to fix the nVidia flickering in 'Nostradamus' and 'Return to Mysterious Island 2' smile
It seems that only some versions of these games were affected somehow, so I have added or recompiled the games' resources (from Russian disks) to the working English EXE files (from Steam versions, as the Russian Steam versions still have the flickering).

Now, the problem remains in "The Secret of Da Vinci", "Treasure Island", "Cleopatra", "Dracula 3" and "Safecracker".
Does anybody per chance have some (international?) versions of these games with no flickering?

Top
#1139227 - 01/22/18 09:13 AM Re: dracula 3 the path of the dragon [Re: Iurii]
Marian Offline
Global Moderator
Sonic Boomer

Registered: 07/04/00
Posts: 34132
Loc: near Yosemite in California
In all of these games I experience the flickering problem, unfortunately.

Top
Page 2 of 3 < 1 2 3 >

Moderator:  Draclvr, Jenny100 

Who's Online
Key: Admin Global Mod Mod Staff  )
1 registered (1 invisible), 151 Guests and 19 Spiders online.
Newest Members
preno280, sunika, leeloo, Sailorfreak, VictorBest
9028 Registered Users