GAMEBOOMERS provides you with all the latest PC adventure computer games information, forum, walkthroughs, reviews and news.
GB Reviews Latest & Upcoming Adventure Games GB Annual Game Lists GB Interviews

BAAGS

GB @ acebook

GB @ witter

About Us
Walkthroughs free games galore Independent Games World of Adventure Patches Game Publishers & Developers GameBoomers Store
Big Fish Games Homepage    
Topic Options
#238507 - 11/13/07 06:30 PM Grim Fandango
SkeeterUK Offline
Addicted Boomer

Registered: 09/07/04
Posts: 1393
Loc: United Kingdom
I have grim and i loved it years ago in 2001.

I have a much beefier pc and when i tryed installing half a year ago on win xp with my 2gb ram and x1950pro 512mb card and audigy2 zs sound card. I couldnt get antiantilising to work (smooths jaggie edges off the polygons (models) and also the game rebooted my pc whenever i saved or attempted to enter the menu "options" i think it was.

Im lookin for some advice how to play this with aa on and without crashing. I was thinking of dosbox but grim is a win95 game so not sure if it would work.

Anyone got any thoughts? I did think it might work on my mothers pc which is a p2 333 computer but the sound was very slow and gameplay was too, and no aa as the gfx card was too old. So brought the game back to my house to retry on here.

Top
#238508 - 11/13/07 06:42 PM Re: Grim Fandango [Re: SkeeterUK]
Jenny100 Online   content
GB Reviewer Glitches Moderator
Sonic Boomer

Registered: 10/24/00
Posts: 35620
Loc: southeast USA

Top
#238509 - 11/14/07 11:19 AM Re: Grim Fandango [Re: Jenny100]
infernoj13usa Offline
The Radiant Moderator Staff Reviewer
BAAG Specialist

Registered: 06/07/02
Posts: 5766
Loc: FT. Worth ....Where the West b...
Here's some more info on the patch that Jenny100 gave you.

http://www.lucasarts.com/support/update/grim.html

inferno
_________________________
Watching: Dark Shadows
Reading: Angelique's Descent
Playing: WoW and living in Kil' Jaeden

Top
#238510 - 11/14/07 04:41 PM Re: Grim Fandango [Re: SkeeterUK]
metzomagic Offline
Settled Boomer

Registered: 11/03/04
Posts: 557
Loc: Dublin, Ireland
Skeeter, hi,

I'll bet nearly anything your stability problems with Grim are due to hyperthreading, a known problem with Grim and XP that everyone seems to keep forgetting about duh

Please have a look at the 'Legacy Games & Hyperthreading' page at the top of the GLITCHES, BUGS & PATCHES forum (visible when you are outside any topic).

Cheers,
MetzO'Magic
_________________________
Now playing:
The Witcher

Running old games in XP/Vista? Then visit Steve's XP Corner!

Top
#238511 - 11/26/07 06:41 PM Re: Grim Fandango [Re: metzomagic]
SkeeterUK Offline
Addicted Boomer

Registered: 09/07/04
Posts: 1393
Loc: United Kingdom
Im playing it right now, i have a weird time playing tho as i have to play in win 95 compat mode to get the game workin properly, but the cutscenes stutter like madness, so i have to save, exit, take compatability off, go in game load up and cutscene plays nice, then save after its done and turn back compat 95 mode on and load the game and keep playing, i do this every time theres a cutscene, maybe not if its tiny cutscene but not for long ones as i wana watch em smooth and sound/voices properly. Unfotunatly u cant keep compat mode off cos sooner or later sounds disappear etc.

Top
#238512 - 11/28/07 07:43 AM Re: Grim Fandango [Re: SkeeterUK]
metzomagic Offline
Settled Boomer

Registered: 11/03/04
Posts: 557
Loc: Dublin, Ireland
So... you disabled hyperthreading via imagecfg then?

MetzO'Magic
_________________________
Now playing:
The Witcher

Running old games in XP/Vista? Then visit Steve's XP Corner!

Top
#238513 - 11/28/07 10:24 AM Re: Grim Fandango [Re: metzomagic]
Cathy1 Offline
BAAG Specialist

Registered: 05/10/03
Posts: 7280
Loc: Calgary Alberta Canada
I'm playing it right now on my new XP and it plays like a charm.
I'm using 98/ME compatibility mode with the patch that fixes the crash at the loader and the crane area. I don't have hyper threading on this computer. I used the in game mode for 3d and it works fine. I also had to set the game to 16 bit colors.

Cathy


Edited by Cathy1 (11/28/07 10:55 AM)
_________________________
" If Cornoil Comes From Corn
Where Doe's Babyoil Come From "

Top
#238514 - 11/28/07 02:25 PM Re: Grim Fandango [Re: Cathy1]
SkeeterUK Offline
Addicted Boomer

Registered: 09/07/04
Posts: 1393
Loc: United Kingdom
I dont have hyperthreading, i have a true dual core (amd x2 3800+) so its a bit diff to p4 hyperthreading. Also its dead easy to alt and tab out of game go to task manager go to processes right click on grim set affinity option then make sure only 1 tick for 1 core then apply and go back to game, tho tbh i didnt notice any diff with two or 1 cores in use.

Btw just so you know hyperthreading is where 1 cpu processor is split into two virtual cores so its like a virtual dual core cpu. And its not xp related its purely a cpu thing. If you have a p4 with hyperthreading then it will be just easier to turn it off in the bios so ur cpu is 1 core again instead of a split cpu into two virtual cores.

Unfortunatly with a real dual core cpu like mine u cant just turn off dual core ability like hyperthreading. But u can limit software like games to use 1 core or both.

===========================================================

Fix the stuttering on win95 and win98 modes, i have a ati video card you see and theres a feature called catalyst ai, i had that set on disabled which caused the choppy cinematics. Put it on standard and it works now so i now play in win98 mode great. smile

Shame the antiantilising doenst work as i hate jaggies and with a costly video card like mine i demand aa to work on any game. But alas gf is so old the drivers dont support aa for grim anymore. frown

Hmm actually that might not be it totally. As when i loaded the game up again it was stuttering again even with catalyst ai set to standard.

BUT!! i can now confirm the cinematic stuttering cause is caused by. It is caused by task manager/processes (grim fandango) its using normal priority. To fix the stuttering simple right click on grim fandango in task manager/processors section and set pirority to low i duno if this will also help but cant hurt, also adjust your dual core/hyperthreading cpus to 1 core of the 2. Like below.

Mods, id prefer if the pictures were kept to show instead of being links, it will be quicker for ppl.

Start grim. Alt and tab keys together to get you back to desktop. Right click on the bottom bar on your desktop and select task manager. Next select processors tab. Find grimfandango.exe and right click you will see at bottom of pop up window 2 options.

1. Set Priority, change to this to fix cinematic and sound stuttering.



2. Set Affinaty. (for dual core or hyperthreaded computers) Bot sure if it helps but might be best for grim. So make sure theres one tick as shown. (tho for me personally grim works fine regardless of 1 or 2 cores so for me dualcore isnt a prob, duno about hyperthreading as i dont have a p4 which that is the only cpu range to use that algorith i believe and was dropped when true dual core and quad core cpus came out). I provide the screenshot and this entry for those who may have probs with grim running on p4 range or similar cpu based computers that used the old hyperthreading method.



Hopefully this will help people like me who had problems with stuttering sound and cinematics.

Do not forget also to use win98 compatability mode


Edited by infernoj13usa (11/29/07 09:06 AM)
Edit Reason: stacking

Top
#238515 - 11/28/07 08:07 PM Re: Grim Fandango [Re: SkeeterUK]
Robert Offline
Addicted Boomer

Registered: 05/25/05
Posts: 4838
Loc: Pinson, Al USA
Quote:
I dont have hyperthreading, i have a true dual core (amd x2 3800+) so its a bit diff to p4 hyperthreading.


Not where this game or any other game that has problem with hyperthreading are concerned. You need to use that program that metzo mentioned to bind this game to a single core.

Quote:
Btw just so you know hyperthreading is where 1 cpu processor is split into two virtual cores so its like a virtual dual core cpu.



It's one physical core and one virtual core. Metzo is well aware of the difference. It's the same theory. Your 2nd core (physical or virtual) could cause conficts.

Quote:
Unfortunatly with a real dual core cpu like mine u cant just turn off dual core ability like hyperthreading


You most certainly can. That program Metzo has will do it. It can also be done in task manager-->set affinity, or in your BIOS.

**edit**

Setting the affinity is what metzo has been trying to tell you all along. The imagecfg application Metzo told you about does the exact same thing as the instructions you posted above for setting affinity. It just does it automatically when the game launches instead you having to do it manually each time you open the game. This is because you can't alt-tab or crtl+alt+del out of the game on some systems.
_________________________
My Gameplay Videos

Top
#238516 - 11/28/07 08:37 PM Re: Grim Fandango [Re: Robert]
SkeeterUK Offline
Addicted Boomer

Registered: 09/07/04
Posts: 1393
Loc: United Kingdom
I know a bit about hardware and software, i know he mentioned imagecfg but i didnt need it as i knew how to make it use 1 core. Im grateful for the advice on the tool but i didnt need it in the end.

Yeah about sometimes you cant alt and tab, then that tool would be useful to me but i have alot of ways to get to the desktop, i.e ctrl and esc and others. Some work some dont.

In the end hyperthreading/dualcore (depending on what technology ur using) didnt cause any trouble for me with grim, it works with 2 cores fine actually. The prob in the end was the priority settings, at default the game stutters when cut scenes play and sound get choppy with it. Lower it to low setting and it 98% cures the prob. No crashing either. smile

Thx for all suggestions people. It took awhile to find the cause problem but i got their in the end. smile I appreciate all the posts that were posted too. wink

Top
#238517 - 11/28/07 08:45 PM Re: Grim Fandango [Re: SkeeterUK]
Robert Offline
Addicted Boomer

Registered: 05/25/05
Posts: 4838
Loc: Pinson, Al USA
Quote:
I know a bit about hardware and software,


Yeah, I can tell that you do. Most younger kids (I call you a kid because I'm 47) that are heaviliy into PC gaming do know their way around a computer.


There are some examples of some dual core or hyperthreading CPUs having issues with older games, while other models don't. For example, many AMD dual core CPUs cause Far Cry to run way too fast, while Pentium dual cores don't have that problem....so it really depends on the specific processor's architecture.

Glad you got it sorted out smile
_________________________
My Gameplay Videos

Top


Who's Online
Key: Admin Global Mod Mod Staff  )
14 registered (gymcandy1, Marian, BrownEyedTigre, macmac, Jenny100, manxman, BubbaJake, Ewil02, Koala, 1 invisible), 55 Guests and 14 Spiders online.
Newest Members
Mr_Underhill, Lani, Rachissa, marmarmargar, deadbringer
8579 Registered Users