Tried in vain to install VMAdditions - Virtual PC '07

Posted by: cruise02

Tried in vain to install VMAdditions - Virtual PC '07 - 09/28/12 06:00 PM

Tried all afternoon to install VMAdditions in VPC '07 after installing a Win 3.11 VM in my Win 7 Acer (host PC) - why can't I any longer install vmadditions? Its install/setup program no longer runs for me.

This setup program used to run ok for me, after creating a new VM, but now this is a thing of the past.

I created this VM Win 3.xx guest from a MS-DOS VM that I created back in January 2012.

Why does not the VMadditions setup program no longer run for me?


@Inland, Jenny, did this ever happen to you?
Posted by: Jenny100

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/28/12 06:13 PM

I don't think VMware Additions was made to be used with 16-bit operating systems like Windows 3.1 and MS-DOS. You should be able to run the virtual machine without them though.
Posted by: cruise02

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/28/12 06:23 PM

I recall having an win 3.11 VM and running Cassandra Galleries in it, got funny graphics and installing vmadditions fixed it, so I'm remembering from this experience.

Also today I found (by googling) how to make Windows 3.11 start up atomatically upon starting the guest - just add "win" to the very last line in the autoexec.bat file - tried this, it worked!

I know the part about fixing the funny graphics after installing Cassandra Galleries has something to do with either installing/updating the s3 video driver in Virtual PC - and if this is all that's involved for this kind of situation (as with Cassandra Galleries) how/where do I do this or get it?
Posted by: Jenny100

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/28/12 07:05 PM

Why don't you just play Cassandra Galleries in a Windows 95 or 98 VM?
Posted by: InlandAZ

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/28/12 08:06 PM

I seem to recall that Virtual PC 2007 omitted the DOS Virtual Machine Additions (which is what you would need for Windows 3.1).

Google Virtual PC 2004 VM Additions and see what turns up. You can do the same for the S3 Video drivers.

I have them somewhere if you can't locate them.
Posted by: cruise02

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/29/12 10:25 AM

@Inland, I tried googling, but got nowhere, I tried in vain (again) after googling, why do I always try to do things in vain?

I guess I'll have to ask you for the VM additions, then, Inland, thanks.

How am I ever going to be a good tech this way?
Posted by: Jenny100

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/29/12 10:35 AM

Google will give you a link to the S3 driver site here
http://www.s3graphics.com/en/drivers/legacy_software_archive.aspx

That link is really slow, but if you do a Google search for the name of the driver, w3117004.zip you can find a faster download site for it here
http://vpc.essjae.com/w3117004.zip

You can find instructions for installing the Virtual PC 2004 additions on Virtual PC 2007 here
http://blogs.msdn.com/b/virtual_pc_guy/a...r-vpc-2007.aspx
Posted by: cruise02

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/29/12 10:51 AM

Originally Posted By: Jenny100
Google will give you a link to the S3 driver site here
http://www.s3graphics.com/en/drivers/legacy_software_archive.aspx

That link is really slow, but if you do a Google search for the name of the driver, w3117004.zip you can find a faster download site for it here
http://vpc.essjae.com/w3117004.zip

You can find instructions for installing the Virtual PC 2004 additions on Virtual PC 2007 here
http://blogs.msdn.com/b/virtual_pc_guy/a...r-vpc-2007.aspx


(sigh) When will I ever learn (but thanks, Jenny)?
Posted by: InlandAZ

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/29/12 12:58 PM

The most stable WFW VM's are those that run under DOSBox. All you have to do is install the S3 video drivers to get 256 color support.
Posted by: cruise02

Re: Tried in vain to install VMAdditions - Virtual PC '07 - 09/29/12 01:44 PM

I had since forgotten (but remembered a moment ago) that I had the s3 driver, sb16 driver backed up on a CD from several years ago when I installed Win 3.11 into DOSbox - how could I have completely forgotten this yesterday when I kept trying in vain? (smacks head).


From this CD backup I installed both the s3 and sb16 drivers - the whole thing went without a single problem, no frustration nor "trying in vain" at all.