GB HOMEPAGE

Moebius

Posted By: Winfrey

Moebius - 07/21/21 03:36 PM

Just bought this and can't get this to work properly. The curses sticks and doesn't want to move... jerks around and when I get it some where an click it is a hit and miss... anyone get this to play.. I am on 10 and tried all the compatibility's 8, 7, xp even tried windowed?? Bought directly from Phoenix
Posted By: Marian

Re: Moebius - 07/21/21 04:00 PM

If no one is able to help you out here, I would suggest going here and sending an email to the address listed under technical help and support.
Posted By: Winfrey

Re: Moebius - 07/21/21 06:46 PM

Gave up and pulled out my old Dell XPS, Windows XP. Yep, it works.

ps I had already sent in my problem to them...lets see if they ever respond...trust this site more than I do the Company's
Posted By: Draclvr

Re: Moebius - 07/21/21 07:31 PM

I was just going to suggest your old XP computer! It may have been the video card in your Windows 10 or something else. Is this the Empire Rising game? GOG and STEAM also have it.
Posted By: oldbroad

Re: Moebius - 07/21/21 08:18 PM

The GOG version worked fine on my Windows 7 computer (way back when I played it anyway).
Posted By: Uncle Reg

Re: Moebius - 07/23/21 05:05 AM


I had this game running on my Win 7 64 back when it first came out. I only played a very little bit of it, but it worked OK. This thread reminded me that I hadn't played it, so I reinstalled it. I don't remember why I uninstalled it in the first place. When I started it, I get the same results as Winfrey described. The mouse is very sporadic and sluggish, sometimes stopping moving. I remembered that the game worked OK when i first had it installed, so I found an earlier version and a patch that I had saved on a WD My Book external USB hard drive. I uninstalled and installed the earlier version and the patch, and it works good. I checked with GOG, and the first one I installed is still the latest version. I had downloaded it in 2016, but it hasn't been updated since. I re-downloaded it and tried it again, and it still didn't work. The first time I tried XP compatibility and that didn't work. When I had the older working version installed, I noticed that the shortcut was checked to Run As Administrator, so I tried it on the second non-working install, and it didn't do any good either. The non-working one has a 1.52 (possibly a version number) on the main menu, but there was no number on the earlier one that works. The file from GOG that didn't work was SETUP_MOEBIUS_2.2.0.9.exe, and the older files that did work were SETUP_MOEBIUS_2.0.0.4.exe and PATCH_MOEBIUS_2.0.2.6.exe.

Good luck with getting any response from that Technical Help and Support email address. 2 years ago I had an issue with one of their other games and I sent an email to that address. I never got a reply. Six months later I found a different email address in one of their promotional emails, and I tried again, and that one worked and the issue was eventually resolved. The address that worked was support@************ instead of help@***********.
Posted By: Winfrey

Re: Moebius - 07/23/21 04:58 PM

I have sent emails to both help and support, so far no response... doesn't matter it is running great on the Dell XPS. What a difference it is to play on the XPS... so big and HEAVY but the picture is great... going to have to pull some of my older games with cd's and play them on this...
Posted By: Uncle Reg

Re: Moebius - 07/23/21 05:40 PM


Are you using the GOG version?
Posted By: Marian

Re: Moebius - 07/23/21 05:47 PM

In her first post, Winfrey states that she bought the game from Phoenix Online Studios.
Posted By: Uncle Reg

Re: Moebius - 07/23/21 11:31 PM


Sorry, I missed it.
Posted By: Marian

Re: Moebius - 07/23/21 11:34 PM

No worries, Uncle Reg. I appreciate your trying to help!
© 2022 GameBoomers Community