GAMEBOOMERS provides you with all the latest PC adventure computer games information, forum, walkthroughs, reviews and news.

GB Reviews

Latest & Upcoming Adventure Games

GB Annual Game Lists

GB Interviews


GB @ acebook

About Us


free games galore

Game Publishers & Developers

World of Adventure


GB @ witter

GameBoomers Store

Big Fish Games Homepage
Topic Options
#96040 - 05/14/02 08:53 PM Nautilus-Stuck
BillyBob Offline
BAAG Specialist

Registered: 01/18/01
Posts: 7858
Loc: North Florida
I'll skip the part before I got past the fan in the ventilator. I have found or done:
Put fuses in the fuse box; belt on a set of pulleys; put one bolt on a gear; installed one gear; used the rod; fixed the projector; solved the gas (levers) puzzle; put the cable onto the circuit in the area between the gear room and the living quarters; solved the steering wheel puzzle; all I have now are the boots, ice pick and claw. Cannot get into the room from the Museum or operate the lever in the gear room or get the chains and motors working and cannot get back thru the fan ventilator to get to the room with the combination lock. I don't know what should be the next thing to do and I don't want to know more than what to find that will make me start to progress again.

Thanks for any help. Sorry if my frustration is showing but have some other "real" problems going. frown
I didn't do it......and if I did I'm not guilty!

#96041 - 05/14/02 09:28 PM Re: Nautilus-Stuck

Have you found both bolts? Spoiler if you want to see

one is by a pillar by the spiral stairs and one is by the chains..hard to see.
Hope this helps you.


Who's Online
Key: Admin Global Mod Mod Staff  )
9 registered (aretha, looney4labs, revco, TLC, Sassy, manxman, Laurie, susanlouise, rockingrjranch), 136 Guests and 14 Spiders online.
Newest Members
Sunward_Games, Steelerfan, MaryJane, paskdigia, Cody_Senn
8993 Registered Users