GAMEBOOMERS provides you with all the latest PC adventure computer games information, forum, walkthroughs, reviews and news.

GB Reviews

Latest & Upcoming Adventure Games

GB Annual Game Lists

GB Interviews


GB @ acebook

About Us


free games galore

Game Publishers & Developers

World of Adventure


GB @ witter

GameBoomers Store

Big Fish Games Homepage
Topic Options
#854797 - 12/08/12 10:11 PM Ceremony Of Innocence
MyGreenEyes Offline
Settled Boomer

Registered: 06/14/02
Posts: 360
Loc: Phoenix, AZ.
I have owned this game for years and can never get it to play. I have a Windows 7 laptop. Everytime I try to load it, it says there is a problem with installing Direct X. I tried to download Direct X from another site, but the game still does not play. What do I need to do for this game to play on my computer?

#854811 - 12/08/12 11:15 PM Re: Ceremony Of Innocence [Re: MyGreenEyes]
Jenny100 Offline
GB Reviewer Glitches Moderator
Sonic Boomer

Registered: 10/24/00
Posts: 38875
Loc: southeast USA
Have you tried running the game in Compatibility mode? Maybe that would get past the DirectX check. You can try downloading DirectX 9.0c libraries from ***Microsoft***, but if you've played other adventure games on this computer, the problem isn't that you don't have DirectX.

Ceremony of Innocence was published in 1997. As far as I can tell from the instructions, the game plays directly from the CD and has no installation (except maybe a folder for your saved games). It does require QuickTime 2.1 and apparently some ancient version of DirectX.

The game may be trying to install DirectX 3 or DirectX 5, which are from around 1997. It sounds like the game is trying to check whether DirectX is installed and can't detect it because it is too new, or because you have a 64-bit version of Windows and the game doesn't know where to look.

There may be an additional problem with QuickTime because the game uses QuickTime 2.1 -- very old, and may even contain 16-bit code.

This is the kind of game I'd play in Virtual PC, but see if Compatibility mode works. If the autorun screen pops up, close it and browse to the CD. Right-click the ceremony.exe file and choose Properties, then the Compatibility tab. Set compatibility to Windows 95 in the dropdown box and put checks in the boxes for "disable visual themes" and "disable desktop composition." Also check the box for "Run this program as administrator" (if you see it). Then OK the changes and see if the game works.

#855083 - 12/09/12 07:41 PM Re: Ceremony Of Innocence [Re: MyGreenEyes]
MyGreenEyes Offline
Settled Boomer

Registered: 06/14/02
Posts: 360
Loc: Phoenix, AZ.
Thank you. I have done what you told me to, but still no luck. I will uninstall, turn off the computer, then reinstall and try again. Hopefully a 2nd time will work. Maybe I'm not meant to play this game. Thanks for the response.


Moderator:  Draclvr, Jenny100 

Who's Online
Key: Admin Global Mod Mod Staff  )
5 registered (Mikael, oldbroad, manxman, gymcandy1, soot), 135 Guests and 12 Spiders online.
Newest Members
GreatDetective, conrad32, Divyansh_Verma, jesblood, Meems
9014 Registered Users